Posted by: ebourlotos on 22 September 2020, 8:46 pm EST

    • Post Options:
    • Link

    Posted 22 September 2020, 8:46 pm EST - Updated 30 September 2022, 12:39 am EST

    Hi, Can anyone help on this one?

    2015 v2

    I have a wijmo grid being used for reporting purposes.

    it is a generic reporting mechanism and the grid behaves as intended.

    It uses groupings and totals (to various levels) (no paging we scroll)

    We populate it with a datatable

    The fields are generated from code behind as c1boundfield and applied to the grid then the datasource is bound

    we do not autogenerate columns

    Problem 1

    When exporting to XLS using the service it generates an adequate look of the grid.

    First Example

    Image1 = grid

    Image2 = XLS result

    Image 3 = CSV result

    The Start Date in the XL output has been shifted over by 1 column and overwrote the column alongside

    in the below shot the start date is blank whereas the data contained a date

    and the length of service coulmn is showing the formatstr instead of the values, in some columns its showing dd MMM yyyy instead of the date values

    Problem 2

    A more complex grid

    But it too is incorrectly exported.

    It seems all grouping columns are being included in the output for both XLS and CSV as art of the dtail, the result is missing information Such as Workdate being overwritten by staff name

    First Image is the Grid

    then XLS image

    then CSV Image

    Does anyone have any ideas?

    Thanks for any help


  • Posted 23 September 2020, 7:24 pm EST

    Hello Evan,

    We are sorry for the inconvenience, we are unable to replicate the issue at our end with the latest build. Please refer to the attached sample and share your DLL version.

    Also, please share modified the sample which replicate your issue so that we may investigate further.


    Manish Gupta.


  • Posted 30 September 2020, 5:15 pm EST

    Hi Manish

    Unfortunately I am using 4.0.20152.218

    of c1.web.wijmo.controls.4

    So once I have modified the supplied project and then direct it to my conversion service (or the C1 demo ones) I end up with the same result.

    I believe its the complexity and depth of grouping which is causing the issue.

  • Posted 5 October 2020, 6:23 pm EST


    We tried to replicate the issue with the same version, but unfortunately, we are not able to replicate the issue at our end.

    Could you please modify the attached sample depicting your issue so that we may investigate and assist you accordingly?


    Manish Gupta


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels