Datafields lost after upgrading

Posted by: david.sheppard on 25 April 2022, 7:03 am EST

  • Posted 25 April 2022, 7:03 am EST

    I am upgrading our programs from version 13.45 to v15.

    In the project, I remove all references to the version 13 for farpoint and grapecity. I add references to the version 15 of the farpoint and grapecity libraries.

    I am using the spread controls linked to a datasource. After I have changed the libraries the spread controls look correct in forms designer. When I open the spread designer everything looks the same as before upgrading the libraries except that the data field properties have no values. If I enter data field values and apply the changes on exiting the spread designer, the data fields are not saved. The autogenerate columns property is always false in these spread controls.

    Any ideas how I can get the datafields not to be lost during upgrading the libraries or how to get the spread designer to save the changes?

  • Posted 25 April 2022, 4:23 pm EST


    We could not replicate the issue at our end. Could you please share a sample replicating the issue and a GIF showing the steps and issue so that we can investigate this further at our end?



  • Posted 25 April 2022, 10:28 pm EST

    Attached is a C# project.

    1. On form 1 there are several spread controls with customized formatting.
    2. I close form1.cs
    3. I open the form3.cs in the forms designer
    4. I expand the references section of the solution explorer and delete all farpoint and grapecity references
    5. I add a spread version 15 control on to form3.cs. This adds all of the version 15 farpoint and grapecity references.
    6. I open form1.cs. When I open the spread designer the datafields are gone.

      QRT2 -
  • Posted 26 April 2022, 2:43 pm EST


    We were able to see the issue at our end, it seems like a bug. We have reported it to the development team and will let you know as soon as we have any updates.



    [Internal Tracking ID : SPNET-23767]

  • Posted 26 April 2022, 8:10 pm EST

    Thank you. Thank you. I think this is the first time that it was a bug and not something that I did wrong.

  • Posted 5 May 2022, 9:47 pm EST

    I see that an update to v15.1.20221.0 has been posted. How can I find out if an update has fixed the issue?

  • Posted 6 May 2022, 3:52 am EST

    Hi David,

    The recent update is the Spread 15 SP1 release. The ETA for the fix for this issue is the Spread 15 SP2 release. We will let you know if we have any updates.



  • Posted 30 July 2022, 10:48 pm EST

    Hi, Do you have a date for when this issue will be fixed? It is 3 months from my last request. We would very much like to update Spread to the newest version.

  • Posted 31 July 2022, 2:04 pm EST

    Hi David,

    The issue has been fixed in the Spread 15 SP2 release. Please install the latest Spread 15.2 using the installer from

    If you face any issues, let us know.



  • Posted 3 September 2022, 10:30 pm EST - Updated 30 September 2022, 4:09 am EST

    I updated the spread control and updated the references in the project using the procedure described earlier in this thread. The code compiles and runs so that is some improvement.

    The problem now is that the form cannot be viewed in the form designer. The error now is that in the form designer initialization section the .getsheets(0) command returns nothing when in design mode. .getsheets(0) is the command that is automatically inserted after the command new New FarPoint.Win.Spread.FpSpread

       Me.BookRelease = New FarPoint.Win.Spread.FpSpread(FarPoint.Win.Spread.LegacyBehaviors.None, CType(resources.GetObject("tlpRelease.Controls"), Object))
       Me.BookRelease_Sheet1 = Me.BookRelease.GetSheet(0)

  • Posted 6 September 2022, 3:00 pm EST


    We were able to see the issue while upgrading from Spread 14.2 to Spread 15. We have escalated the issue to the development team and will let you know as soon as we have any updates.



    [Tracking ID : SPNET-26481]

  • Posted 6 September 2022, 9:46 pm EST

    Thank you.

    We are currently using Spread version 13.45 and I do not want to keep falling further behind. Would we encounter the same issue if we were to upgrade to a version 14 of spread while we waited for the fix to spread v15?

    How can I download a version 14 of spread?

  • Posted 8 September 2022, 1:54 pm EST - Updated 30 September 2022, 4:09 am EST

    Hi David,

    We apologize for the delay. The development team is working on the issue.

    You can install Spread 14 from the installer from You just need to choose the version you want to install in the top-left Combobox.

    If you face any issues in using Spread 14, please let us know.



  • Posted 12 September 2022, 5:54 pm EST

    Hi David,

    The development team is still investigating the issue. In the meantime, they have suggested a workaround, if you uninstall spread 14 from your system and only keep Spread 15 then the designer should work.



  • Posted 5 October 2022, 8:21 am EST - Updated 5 October 2022, 8:26 am EST

    Sorry for the delay in my response. It took me time to find a computer to test on.

    The workaround did not work. I got a vanilla computer and installed Visual Studio 2019 and Spread version 15. I copied the source code from my normal programming computer to the new computer. I removed the references to the old version of spread and added the spread version 15 using the procedure that I explained previously. There are no other versions of spread on the computer.

    The program compiled and ran correctly. the spread control worked correctly on the running program.

    The forms with the spread control will not load in design mode. Error screen attached. When I click on go to code, the error occurs on the getsheet(0) command in the form designer.

  • Posted 5 October 2022, 8:31 pm EST


    We have shared the information with the development team. We will update you as soon as we get an update from them.



  • Posted 10 October 2022, 9:59 pm EST

    Hi David,

    The development team was unable to replicate the issue. Could you please provide a sample application with a form replicating the issue so we can check it at our end? As per the team, there might be some settings of spread that are serialized with binary serialize of v14, they can not be loaded in design time in v15.

    We have created a case on the Suppor portal since the support portal is not public and you can share the project there without being worried about confidentiality.

    Please continue this thread on the support case [CAS-34958-H4H6S7].



  • Posted 12 October 2022, 12:20 am EST

    I attached an example earlier in this thread. Your development team said that they could replicate the issue.

  • Posted 12 October 2022, 2:28 pm EST

    Hi David,

    We were able to see the original issue in a sample we created but that was resolved by following the method suggested by the development team.

    As you mentioned in your last reply, you were still facing the issue even after uninstalling Spread 14 or using it on a clean machine. Since we can’t replicate this scenario at our end, we would like to investigate the issue at our end, if you could provide a sample application that replicates the issue at your end?



  • Posted 1 February 2024, 6:35 am EST - Updated 1 February 2024, 6:40 am EST

    We are updating our Spread.NET from 16.0.20221.3 to 17.0.20231.0

    The same issue is happening as when we tried to update previous versions where it loses all of the sheet settings that were defined in the spread designer.

  • Posted 1 February 2024, 11:07 pm EST

    Hello David,

    First of all, apologies for the inconvenience caused.

    It is quite strange, as we tried to replicate the issue with the stripped-down sample but the issue did not occur.

    To migrate from Spread 16 to Spread 17, please make sure to remove the old builds and re-add the same builds of Spread 17 version. After this, please make sure to remove the Culture, Version, and PublicKeyToken details from the Licenses.licx file to make it version-independent.

    If you are following any other steps in the upgrade process, then please let us know, and if you could provide us with the stripped-down sample, then it will be very helpful to speed up this investigation.


    Prabhat Sharma.

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels