C1ComboBox Exeption when opened

Posted by: software on 6 October 2018, 3:15 am EST

    • Post Options:
    • Link

    Posted 6 October 2018, 3:15 am EST

    Hello everybody,

    after installing the new build (3.0.20182.318) I have some troubles with C1ComboBox Objects. The Controll throws an execption: ‘Event registration is overwriting existing delegate’ (see Attachement, ) during opening the Dropdown List. It seems that this happens only when the Controlls are inside an UITableViewController. Inside an ViewController everything works fine.

    Any Idea?

    Thank you


    Volker LorenzC1ComboBox Exception.zip

  • Posted 10 October 2018, 7:09 am EST

    Hi Volker

    I haven’t seen that issue yet, but it’s possible something changed with the Xamarin and iOS updates over the last month. Do you have the sample where issue occurred so that we could take a look at it? I tried adding a C1ComboBox into a UITableView, but I didn’t get the exception here (I’m running with all the newest updates).



  • Posted 22 October 2018, 4:13 am EST

    Hi Kelly,

    I’m sorry for the late Reply, but I was busy with another project.

    I checked all versions, I am up to date. It is not so easy to pick a sample out of this Project and for the Moment the Situation is not critical, I can use the previous C1-Version.

    I let you know if I have additional Information.



  • Posted 27 October 2020, 12:51 am EST

    I am now getting this same error trying to put a DropDown within a ViewCell within a TableSection within a TableView. I’m using XF, C1 components are 4.6.20202.468.

    <ViewCell StyleId="none">
                                Text="API Environment"
                                TextColor="{DynamicResource TextPrimaryColor}"
                                VerticalTextAlignment="Center" />
                                ItemsSource="{Binding ApiEnvironments}"
                                SelectedItem="{Binding SelectedEnvironment, Mode=TwoWay}"
                                VerticalOptions="Center" />

    This is one of many view cells. The table view has enough viewcells that it does scroll.

    Any thoughts on what would be causing this?

  • Posted 28 October 2020, 2:35 am EST

    Hi Greg

    I tried with the code snippet provided by you but unfortunately not able to replicate the issue at my end, can you please share a small sample replicating the issue? that will help us to assist you better.


Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels