Could not load file or assembly 'GrapeCity.Documents.Imaging, Version=

Posted by: coolcliff on 21 July 2022, 11:55 pm EST

    • Post Options:
    • Link

    Posted 21 July 2022, 11:55 pm EST

    I’m getting the below error in each control when viewing in designer view in 16.1.3:

    Could not load file or assembly 'GrapeCity.Documents.Imaging, Version=, Culture=neutral or one of its dependencies. the system cannot find the file specified.

    I’ve tried uninstalling references and also reinstalling Visual Studio. It’s strange because it looks like the most recent assembly should be GrapeCity.Documents.Imaging version=, which I have installed.

    Any other specific suggestions?

  • Posted 24 July 2022, 10:23 pm EST


    Could you please try installing the specific version of the above package as requested to see if the issue is resolved? If the issue persists, please try using the “Convert To ActiveReports 16” tool in the Tools menu of VisualStudio. to resolve the dependency issue.

    Furthermore, if you have ActiveReports 13 installed on your system, please try removing the same, and then try rebuilding your project, as it is known to produce some conflict in dependencies with other versions of ActiveReports.

    If the issue persists, please provide a sample depicting the issue so that we may debug it and reply accordingly.


    Dushyant Sharma

  • Posted 27 July 2022, 1:22 am EST

    Thanks for the suggestion! I had AR 12 and AR 16 both installed. I uninstalled AR 12, which seemed to fix the issue.

  • Posted 5 August 2022, 1:20 am EST

    I got the same error. I just have active reports 16 installed. The error started after I updated GrapeCity.Documents.Imaging to v5.1.0.796. The report runs fine, it’s just the designer controls complain. If I downgrade to v5.1.0.790 the problem is fixed.

    Is there a way to update GrapeCity.Documents.Imaging for the designer screen?



  • Posted 7 August 2022, 8:04 pm EST


    We would not recommend upgrading individual packages, instead of doing this, please only upgrade Grapecity.ActiveReports packages. It will automatically upgrade all required DLLs to compatible versions.


    Dushyant Sharma

  • Posted 14 August 2022, 11:25 pm EST

    I am also getting this error. I have visual studio 2022 installed with the latest update.

    I have AR installed.

    When I open the report designer, all of the textboxes are saying the following: Could not load file or assembly ’ GrapCity.Documents.Imaging. Version…

    This is very frustrating.

  • Posted 15 August 2022, 12:44 am EST

    I got the update this morning for the packages that went to, GrapCity.Documents.Imaging etc…

    I am still getting this designer error.

  • Posted 21 August 2022, 3:04 pm EST


    Could you please try performing the below-suggested steps to see if that resolves the issue:

    • Instead of upgrading the above-specified package, please try updating the “GrapeCity.ActiveReports” main NuGet package, updating it should automatically update the required dependencies.

    • Try using the “Convert to ActiveReports 16” utility tool from the Tools Menu of VisualStudio, to see if that resolves the issue.


    Dushyant Sharma

Need extra support?

Upgrade your support plan and get personal unlimited phone support with our customer engagement team

Learn More

Forum Channels